您的位置:首页 > 大数据 > 人工智能

杭电1021 Fibonacci Again

2013-04-12 13:59 375 查看
不解释,自己看吧!

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27175    Accepted Submission(s): 13122


[align=left]Problem Description[/align]
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 

[align=left]Input[/align]
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

 

[align=left]Output[/align]
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

 

[align=left]Sample Input[/align]

0
1
2
3
4
5

 

[align=left]Sample Output[/align]

no
no
yes
no
no
no

1:

#include <iostream>
using namespace std;
int main()
{
int n, i;
__int64 ans, a, b;
while(cin>>n)
{
a = 7;
b = 11;
if(n==1||n==0)
cout<<"no\n";
else
{
ans = 0;
for (i = 2; i<=n; i++)
{
ans=(a+b)%3;
a=b;
b=ans;
}
if(!ans) cout<<"yes\n";
else cout<<"no\n";
}
}
return 0;
}


2:

#include<stdio.h>
main()
{
long n;
while(scanf("%ld",&n)!=EOF)
{
if(n==0||n==1)
printf("no\n");
else if((n-2)%4==0)
printf("yes\n");
else
printf("no\n");

}
}


3:

main()
{
int i;
while(scanf("%d",&i)!=-1)printf("%s\n",i%4==2?"yes":"no");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: