您的位置:首页 > 其它

POJ 3070 Fibonacci【矩阵连乘】

2013-04-09 21:14 260 查看
Fibonacci

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6881Accepted: 4873
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is


.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

Source

Stanford Local 2006

3070Accepted132K0MSC++1162B2013-04-09 21:17:22
#include<cstdio>

const int mod = 10000;

struct Matrix
{
__int64 a11, a12, a21, a22;
}matrix;

Matrix mull(Matrix a, Matrix b)
{
Matrix c;
c.a11 = a.a11*b.a11+a.a12*b.a21;
c.a12 = a.a11*b.a12+a.a12*b.a22;
c.a21 = a.a21*b.a11+a.a22*b.a21;
c.a22 = a.a21*b.a12+a.a22*b.a22;

c.a11 %= mod;
c.a12 %= mod;
c.a21 %= mod;
c.a22 %= mod;

return c;
}

Matrix find(Matrix m, __int64 n)
{
Matrix b;
b.a11 = 1; b.a12 = 0;
b.a21 = 0; b.a22 = 1;
while(n > 0)
{
if(n&1)
{
b = mull(b, m);
}
n = n>>1;

m = mull(m, m);

}
return b;
}
int main()
{
__int64 n;
while(scanf("%I64d", &n) != EOF)
{
if(n == -1) break;
else if(n == 0)
{
printf("0\n");
continue;
}

__int64 a11, a12, a21, a22;
Matrix m, ans;
m.a11 = 1;
m.a12 = 1;
m.a21 = 1;
m.a22 = 0;

ans = find(m, n);

__int64 result = ans.a12%10000;
printf("%I64d\n", result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: