您的位置:首页 > 其它

poj3461——Oulipo(KMP)

2013-04-08 19:22 477 查看
Oulipo
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 15416Accepted: 6179
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T.
All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN
Sample Output

1

3

0

Source
BAPC 2006 Qualification

解析:KMP模板题,刚学了kmp,找一道裸题刷哈!!!

#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<iostream>
using namespace std;
int next[10010];
int lens,lent;
char S[1000010],T[1000010];
void get_next()
{
int i=0;int j=-1;next[i]=j;
while(i<lent)
{
if(j==-1 || T[i]==T[j])
{
++i;++j;
next[i]=j;
}else j=next[j];
}
}
void kmp()
{
int i=0;int j=0; int ans=0;
while (i<lens && j<lent)
{
if(j==-1 || S[i]==T[j]){i++;j++;}else j=next[j];
if(j>=lent)
{
//printf("%d\n",i-lent);注释部分是输出第一次匹配的位置,也可以输出每次匹配的位置
ans++;
j=next[j];
}
}
printf("%d\n",ans);
}

int main()
{
freopen("kmp.in","r",stdin);
freopen("kmp.out","w",stdout);
int test;
cin>>test;
for(int i=1;i<=test;i++)
{
scanf("%s\n",T);
scanf("%s\n",S);
lens=strlen(S);lent=strlen(T);
get_next();kmp();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: