您的位置:首页 > 产品设计 > UI/UE

ZOJ 3659 Conquer a New Region(路径压缩)

2013-04-08 17:00 232 查看
Conquer a New RegionTime Limit: 5 Seconds Memory Limit: 32768 KB
The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output

4
3

路径压缩 (并查集) 并不是动态规划
题目大意:从N个城市中选择一个,使得其他的城市到这个城市的交通效益最大

按边排序,从大到小插入,每条边将两个集合连起来,而新加的边是两个集合所有边最小的,那么两个集合中的点交叉的通路最小的边就是新加的,那只要枚举两个集合,a,b是a并入b更优还是b并入a更优就行了。集合内部点已经计算出,相互的只要知道集合中元素的个数就好了。

所以并查集只需要维护一个集合的元素个数,一个集合的总权值

View Code

# include<cstdio>
# include<cstring>
# include<algorithm>
# define N 200100
using namespace std;
struct Edge
{
int u,v,w;
}edge
;
int f
,num
;
long long cost
;
int find(int u)
{
if(f[u]==u) return u;
return f[u] = find(f[u]);
}
bool cmp(struct Edge a,struct Edge b)
{
return a.w > b.w;
}
int main()
{
int n,i;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<n;i++)
scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
sort(edge+1,edge+n,cmp);
for(i=1;i<=n;i++)
f[i] = i, num[i]=1, cost[i]=0;
for(i=1;i<n;i++)
{
int uu=find(edge[i].u);
int vv=find(edge[i].v);
if(uu!=vv)
{
cost[vv] = max((long long)num[uu]*edge[i].w+cost[vv],
(long long)num[vv]*edge[i].w+cost[uu]);
num[vv]+=num[uu];
f[uu]=vv;
}
}
printf("%lld\n",cost[find(1)]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: