您的位置:首页 > 其它

Sum of Consecutive Prime Numbers

2013-04-06 14:28 357 查看
G - Sum of Consecutive Prime Numbers
Crawling in process...Crawling failedTime
Limit:
1000MS    Memory Limit:65536KB    
64bit IO Format:%I64d & %I64u
SubmitStatus

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13
+ 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 

Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No
other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0


Sample Output

1
1
2
3
0
0
1
2

 //好水的一道题,数据开到10010不行,开到20010竟然过了。。。大家要注意数据的大小,可以测试10007,结果是3;

#include<iostream>
using namespace std;

int f[20010],prime[10000];
int count = 0;

void Prime()
{
for(int i=2;i<=20010;i++)
if(!f[i])
{
prime[count++]=i;
for(int j=i*i;j<=20010;j+=i)
f[j]=1;
}
}
int main()
{
Prime();
int n,sum,xx;
while(cin>>n&&n)
{
xx=0;
for(int i=0;i<count&&prime[i]<=n;i++)
{
sum=0;
int j=i;
while(sum<n)
{
sum+=prime[j++];
if(sum==n)
{
xx++;
break;
}
}
}
cout<<xx<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Sum of Consecutive P