您的位置:首页 > 其它

HDU1171--Big Event in HDU

2013-04-06 11:22 239 查看
[align=left]Problem Description[/align]
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

[align=left]Output[/align]
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.

[align=left]Sample Input[/align]

2
10 1
20 1
3
10 1
20 2
30 1
-1

[align=left]Sample Output[/align]

20 10
40 40


 

/*
两件设施如果分值相同则他们是相同的
一件设备最高的分数是50
最多有50种设备,每种设备最多有100个
所以一个25万的背包就一定能装全部的东西
我们只需要像男人八题那样标记法做,然后从中间
往左边搜最大的数给软件学院
或者弄个一半的背包,看最多能装入多少分。
感觉标记法写起来简单点
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 258888
int use[maxn];
bool vis[maxn];
int v[58],num[58];
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&(n>=0))
{
int sumv=0;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&v[i],&num[i]);
sumv+=v[i]*num[i];
}
vis[0]=1;
for(int i=1;i<=n;i++)
{
memset(use,0,sizeof(use));
for(int j=v[i];j<=sumv;j++)
{
if(!vis[j]&&vis[j-v[i]]&&use[j-v[i]]<num[i])
{
use[j]=use[j-v[i]]+1;
vis[j]=1;
}
}
}
for(int i=sumv/2;i>=0;i--)
{
if(vis[i])
{
printf("%d %d\n",sumv-i,i);
break;
}
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息