您的位置:首页 > 其它

hdu 1059 Dividing ——多重背包复习

2013-04-05 12:29 351 查看

Dividing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11367 Accepted Submission(s): 3168


[align=left]Problem Description[/align]
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

[align=left]Input[/align]
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

[align=left]Output[/align]
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

[align=left]Sample Input[/align]

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

[align=left]Sample Output[/align]

Collection #1: Can't be divided.

Collection #2: Can be divided.

多重背包。
背包九讲多重背包模板:

def MultiplePack(F, C, W, M)
  if C * M >= V
    CompletePack(F, C, W)
    return
  k = 1
  while (k < M)
    ZeroOnePack(k * C, k * W)
    M = M - k
    k = k * 2
  ZeroOnePack(C * M, W * M)


然后就照着写的,这题以前做过,为了复习多重背包,又做了一遍……

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <stack>
#include <queue>
#include <cmath>
#include <algorithm>
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
using namespace std;
typedef long long int LL;
const int MAXN =  0x3f3f3f3f;
const int  MIN =  -0x3f3f3f3f;
const double eps = 1e-9;

int F[20000*6+1], V;
void complete(int c, int w){
for (int v = c; v <= V; ++v)
F[v] = max(F[v], F[v-c] + w);
}
void zeropack(int c, int w){
for (int v = V; v >= c; --v)
F[v] = max(F[v], F[v-c] + w);
}
int main(void){
#ifndef ONLINE_JUDGE
freopen("hdu1059.in", "r", stdin);
#endif
int t = 1, a[7];
while (~scanf("%d", a+1)){
int sum = a[1];
for (int i = 2; i <= 6; ++i){
scanf("%d", a+i); sum += i*a[i];
}
if (!sum) break;
//    if (t != 1) printf("\n");
printf("Collection #%d:\n", t); t++;
if (sum&1){
printf("Can't be divided.\n\n"); continue;
}
V = sum >> 1;
memset(F, MIN, sizeof(F));
F[0] = 0; int k;
for (int i = 1; i <= 6; ++i){
if (!a[i]) continue;
if  (i * a[i] >= V){
complete(i, 1); continue;
}
k = 1;
while (k < a[i]){
zeropack(k * i, k * 1); a[i] -= k; k <<= 1;
}
zeropack(i * a[i], 1 * a[i]);
}
if (F[V] >= 0){
printf("Can be divided.\n");
}
else printf("Can't be divided.\n");
printf("\n");
}

return 0;
}


真不知道hduoj是怎么想的,有时候需要最后一个case要加一个换行,有时候却不需要……比如这题38行的注释就是最后一个case不加空行……结果PE了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: