您的位置:首页 > 其它

HDU1164:Eddy's research I

2013-04-04 20:54 204 查看
Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help
him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .



Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.



Output
You have to print a line in the output for each entry with the answer to the previous question.



Sample Input
11
9412




Sample Output
11
2*2*13*181






#include <stdio.h>
#include <string.h>

int prime[70000];

void sushu(void)
{
    int i,j;
    memset(prime,1,sizeof(prime));
    for(i = 2; i<70000; i++)
    {
        if(prime[i])
        {
            for(j = i+i; j<70000; j+=i)
            {
                prime[j] = 0;
            }
        }
    }
}

int main()
{
    int n,i;
    sushu();
    while(~scanf("%d",&n))
    {
        if(prime
)
        {
            printf("%d\n",n);
            continue;
        }
        int flag = 1;
        for(i = 2; i<=n; i++)
        {
            while(n%i == 0)
            {
                if(flag)
                {
                    printf("%d",i);
                    flag = 0;
                }
                else
                    printf("*%d",i);
                n = n/i;
            }
        }
        printf("\n");
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: