您的位置:首页 > 产品设计 > UI/UE

Guessing Game

2013-03-31 15:52 295 查看
Guessing Game

Stan and Ollie are playing a guessing game. Stan thinks of a number between 1 and 10 and Ollie guesses what the number might be. After each guess, Stan indicates whether Ollie's guess is
too high, too low, or right on.

After playing several rounds, Ollie has become suspicious that Stan cheats; that is, that he changes the number between Ollie's guesses. To prepare his case against Stan, Ollie has recorded a transcript of several games. You are to determine whether or not
each transcript proves that Stan is cheating.

Standard input consists of several transcripts. Each transcript consists of a number of paired guesses and responses. A guess is a line containing single integer between 1 and 10, and a response is a line containing "too high", "too low", or "right on".
Each game ends with "right on". A line containing 0 follows the last transcript.

For each game, output a line "Stan is dishonest" if Stan's responses are inconsistent with the final guess and response. Otherwise, print "Stan may be honest".

Sample Input

10
too high
3
too low
4
too high
2
right on
5
too low
7
too high
6
right on
0

Sample Output

Stan is dishonest
Stan may be honest


解析:题意是猜数字游戏。开始Stan 想一个1到10的数a。然后Ollie 去猜,如果大于a则Stan 说too
high,小于则说too low。如果相等则说right on。但是Stan会说谎,所以通过stan的回答来判断是否Stan说谎。

思路:用一个1到10的数组,来标记还在范围内的数。例如说一个数n,如果给的是too high,则大于等于n的数都可以标记不合法了。

当出现right on时,看数组中是否还有数。如果还有就可以判断Stan可能没说谎。

#include"stdio.h"

#include"string.h"

int main()

{

int n,x,y,i,j,k;

char s[20];

int a[11];

while(scanf("%d",&n)!=EOF&&n)

{

memset(a,0,sizeof(a));

while(gets(s)&&strcmp(s,"right on"))

{

if(!strcmp(s,"too high"))

{

for(i=n;i<=10;i++)

a[i]=1;

}

if(!strcmp(s,"too low"))

{

for(i=n;i>=1;i--)

a[i]=1;

}

scanf("%d",&n);

}

if(a
==0)

printf("Stan may be honest\n");

else

printf("Stan is dishonest\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: