您的位置:首页 > 其它

POJ1703--Find them, Catch them--并查集

2013-03-28 18:01 423 查看
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to.
The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message
as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.In different gangs.
In the same gang.
 
/*
做这一道题收获挺大的。此题裸并查集会超时。用C++的输入输出也会超时。。
做这道题我掌握了并查集的两种优化方法
一:路径压缩
二:按秩合并
说下这道题的大致思路。给出a和b是敌对,那么a和b的祖宗的敌对是同盟,b和a的祖宗的敌对是同盟。
询问的时候,如果a和b同祖宗,显然是同帮派
如果a和b不同祖宗,有两种可能,他们是敌对或者关系还不确定。
只需看a的祖宗的敌对的祖宗和b的祖宗是否相同。。有点拗口额
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int father[100008];
int rank1[100008];
int didui[100008];
/*
裸的
int find(int x)
{
if(x==father[x])return x;
return find(father[x]);
}
递归形式的路径压缩,数据大的时候可能导致栈溢出。
int find(int x)
{
if(x==father[x])return x;
return father[x]=find(father[x]);
}
接下来写成非递归形式的,时间消耗多点。
*/
int find(int x)
{
int k,j,r;
r=x;
while(r!=father[r])
{
r=father[r];
}
k=x;
while(k!=r)
{
j=father[k];
father[k]=r;
k=j;
}
return r;
}
/*
弱弱地说,此题不要按秩合并反而更快点。。。
void Union(int a,int b)
{
int aa=find(a);
int bb=find(b);
father[aa]=bb;
}
*/
void Union(int a,int b)
{
int aa=find(a);
int bb=find(b);
if(rank1[aa]>rank1[bb])
{
father[bb]=aa;
}
else if(rank1[aa]==rank1[bb])
{
father[bb]=aa;
rank1[aa]++;
}
else
{
father[aa]=bb;
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int m,n;
scanf("%d%d",&n,&m);
getchar();
for(int i=1;i<=n;i++)
{
father[i]=i;
}
memset(didui,0,sizeof(didui));
memset(rank1,0,sizeof(rank1));
char c;
int u,v;
for(int i=1;i<=m;i++)
{
scanf("%c%d%d",&c,&u,&v);
getchar();
if(c=='D')
{
//u和v不同,那么u和v的敌对同盟,v和u的敌对同盟
int uu=find(u);
int vv=find(v);
if(!didui[uu])
{
didui[uu]=vv;
}
if(!didui[vv])
{
didui[vv]=uu;
}
Union(v,didui[uu]);
Union(u,didui[vv]);
}
else
{
if(find(u)==find(v))
{
printf("In the same gang.\n");
}
else if(find(didui[find(u)])==find(v))
{
printf("In different gangs.\n");
}
else printf("Not sure yet.\n");
}
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息