您的位置:首页 > 其它

Uva 572 - Oil Deposits(DFS)

2013-03-28 11:13 495 查看
[b] Oil Deposits [/b]
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise

and

. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2


Miguel A. Revilla
1998-03-10

#include<stdio.h>
#include<string.h>
#define MAXN 120

void dfs(char (*alpha)[MAXN], int row, int column, int n, int m)
{
int i, j;
for(j=column-1; j>=0 && alpha[row][j] == '@'; --j)
{
alpha[row][j] = '*';
dfs(alpha, row, j, n, m);
}
for(j=column+1; j<n && alpha[row][j] == '@'; ++j)
{
alpha[row][j] = '*';
dfs(alpha, row, j, n, m);
}

for(i=row-1; i>=0 && alpha[i][column] == '@'; --i)
{
alpha[i][column] = '*';
dfs(alpha, i, column, n, m);
}
for(i=row+1; i<m && alpha[i][column] == '@'; ++i)
{
alpha[i][column] = '*';
dfs(alpha, i, column, n, m);
}

for(i=row+1, j=column-1; i<m && j>=0 && alpha[i][j] == '@'; ++i, --j)
{
alpha[i][j] = '*';
dfs(alpha, i, j, n, m);
}
for(i=row+1, j=column+1; i<m && j<n && alpha[i][j] == '@'; ++j, ++i)
{
alpha[i][j] = '*';
dfs(alpha, i, j, n, m);
}

for(i=row-1, j=column-1; i>=0 && j>=0 && alpha[i][j] == '@'; --i, --j)
{
alpha[i][j] = '*';
dfs(alpha, i, j, n, m);
}
for(i=row-1, j=column+1; i>=0 && j<n && alpha[i][j] == '@'; --i, ++j)
{
alpha[i][j] = '*';
dfs(alpha, i, j, n, m);
}

return;
}

int main()
{
int m, n, cnt, i, j;
char alpha[MAXN][MAXN];
while(scanf("%d%d", &m, &n) != EOF && m)
{
getchar();
for(i=0; i<m; ++i)
{
for(j=0; j<n; ++j)
scanf("%c", &alpha[i][j]);
getchar();
}
cnt = 0;
for(i=0; i<m; ++i)
for(j=0; j<n; ++j)
{
if(alpha[i][j] == '@')
{
cnt++;
dfs(alpha, i, j, n, m);
}
}
printf("%d\n", cnt);
}
return 0;
}


解题思路:

AC率很高这题,思路就不必再遨述了。属于深度优先查找的问题,代码还是不够简得继续学习
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: