您的位置:首页 > 其它

zoj 3204 字典序最小的最小生成树的输出

2013-03-27 13:37 387 查看
Connect them

Time Limit: 1 Second Memory Limit: 32768 KB

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is
the same as connecting computers j and i). The cost of connecting computer i and computer j is cij.
You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.
Given n and each cij , find the cheapest way to connect computers.

Input
There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.
The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers
separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij =
0 means that you cannot connect them). 0 <= cij <= 60000, cij = cji, cii = 0, 1 <= i, j <= n.
Output
For each test case, if you can connect the computers together, output the method in in the following fomat:
i1 j1 i1 j1 ......
where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space
at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1"
in the line.
Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0


Sample Output

1 2 1 3
-1


Hints:

A solution A is a line of p integers: a1, a2, ...ap.

Another solution B different from A is a line of q integers: b1, b2, ...bq.

A is lexicographically smaller than B if and only if:

(1) there exists a positive integer r (r <= p, r <= q) such that ai = bi for
all 0 < i < r and ar < br

OR

(2) p < q and ai = bi for all 0 < i <= p
此题关键在最小生成树的输出要按照字典序最小的输出,用kruscal算法求解。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 110
int Father[maxn];
struct Edge
{
int from;
int to;
int w;
}edge[maxn*maxn],path[maxn*maxn];

int n,tol,cnt;
void addedge(int u,int v,int w)
{
edge[tol].from=u;
edge[tol].to=v;
edge[tol].w=w;
tol++;
}

bool cmp1(Edge a,Edge b)
{
if(a.w!=b.w)return a.w<b.w;
else if(a.from!=b.from)
return a.from<b.from;
else
return a.to<b.to;
}

bool cmp2(Edge a,Edge b)
{
if(a.from!=b.from)
return a.from<b.from;
else
return a.to<b.to;
}
//ksuscal求最小生产树
int find(int x)
{
if(Father[x]==-1)return x;
return Father[x]=find(Father[x]);
}

void kruscal()
{
memset(Father,-1,sizeof(Father));
cnt=0;
for(int i=0;i<tol;i++)
{
int u=edge[i].from;
int v=edge[i].to;
int t1=find(u);
int t2=find(v);
if(t1!=t2)
{
path[cnt++]=edge[i];
Father[t1]=t2;
}
}
}
int main()
{
int cas;
cin>>cas;
while(cas--)
{
tol=0;
cin>>n;
int val;
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
cin>>val;
if(j<=i||val==0)continue;
addedge(i,j,val);
}
}
sort(edge,edge+tol,cmp1);
kruscal();
if(cnt!=n-1)
{
cout<<"-1"<<endl;
}
else
{
sort(path,path+cnt,cmp2);
for(int i=0;i<cnt-1;i++)
cout<<path[i].from+1<<" "<<path[i].to+1<<" ";
cout<<path[cnt-1].from+1<<" "<<path[cnt-1].to+1<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: