您的位置:首页 > 其它

HDU 1171 Big Event in HDU(多重背包)

2013-03-26 20:09 369 查看

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15812 Accepted Submission(s): 5574



[align=left]Problem Description[/align]
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

[align=left]Output[/align]
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.

[align=left]Sample Input[/align]

2
10 1
20 1
3
10 1
20 2
30 1
-1


[align=left]Sample Output[/align]

20 10
40 40 多重背包问题AC代码:#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int dp[250000+5];

int MAX(int a,int b)
{
return a>b?a:b;
}
int MIN(int a,int b)
{
return a<b?a:b;
}
int main()
{
int w[55],a[55];
int t;
while(cin>>t)
{
if(t<0)
break;
int sum=0;
for(int i=1;i<=t;i++)
{
cin>>w[i]>>a[i];
sum+=w[i]*a[i];
}
int sum1=sum/2;
memset(dp,0,sizeof(dp));
for(int i=1;i<=t;i++)
for(int j=1;j<=a[i];j++)
for(int p=sum1;p>=w[i];p--)
{
dp[p]=MAX(dp[p],dp[p-w[i]]+w[i]);
}
cout<<MAX(dp[sum1],sum-dp[sum1])<<" "<<MIN(dp[sum1],sum-dp[sum1])<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: