您的位置:首页 > 其它

HDU1213:How Many Tables

2013-03-24 23:07 267 查看
Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.



Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.



Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.



Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5




Sample Output
2
4



并查集的基础题

我擦

我的find函数如果写成

int find(int x)
{
    int r = x;
    while(father[r] != r)
        r = father[r];
    return r;
}


就会超时,谁跟我说这个函数用时还少些的,我下面的代码15ms,用了这个就超时了

#include <stdio.h>

int father[1005];

int find(int x)
{
    int next;
    if(father[x]==x)
    return x;
    return father[x]=find(father[x]);
}

void Union(int x,int y)
{
    father[x] = y;
}

int main()
{
    int n;
    int a,b,i,j;
    int x,y,fx,fy;
    int ans;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&a,&b);
        for(i = 1; i<=a; i++)
            father[i] = i;
        while(b--)
        {
            scanf("%d%d",&x,&y);
            fx = find(x),fy = find(y);
            if(fx!=fy)
            Union(fx,fy);
        }
        ans = 0;
        for(i = 1; i<=a; i++)
            if(father[i] == i)
                ans++;
        printf("%d\n",ans);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: