您的位置:首页 > 其它

1119. Factstone Benchmark

2013-03-22 00:21 337 查看
1119. Factstone Benchmark

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)

Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Input

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?

Output

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.

Sample Input

1960

1981

0

Sample Output

3

8

感觉主要折磨人的地方在于如何防止数据溢出的问题。采用log去对数的思想是从百度上看到的,这里附上地址:http://blog.csdn.net/betabin/article/details/7788231

#include<stdio.h>

#include<math.h>

int main(){

int n;

scanf("%d",&n);

while(n!=0){

int i,bit,counter=0;

for(i=1960;i<=2160;i+=10){

if(n>=i && n<(i+10)){

bit=pow(2,counter+2);

break;

}

counter++;

}

int x=2;

double y=0;

while(y<=bit){

y+=log(x)/log(2);

x++;

}

x-=2;

printf("%d\n",x);

scanf("%d",&n);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: