您的位置:首页 > 其它

Second-price Auction

2013-03-21 22:13 218 查看
点击打开链接

Second-price Auction
Crawling in process...Crawling failedTime
Limit:
1000MS    Memory Limit:32768KB    
64bit IO Format:%lld & %llu
SubmitStatus

Description

Do you know second-price auction? It's very simple but famous. In a second-price auction, each potential buyer privately submits, perhaps in a sealed envelope or over a secure connection, his (or her) bid for the object to the auctioneer. After receiving
all the bids, the auctioneer then awards the object to the bidder with the highest bid, and charges him (or her) the amount of the second-highest bid.

Suppose you're the auctioneer and you have received all the bids, you should decide the winner and the amount of money he (or she) should pay.

Input

There are multiple test cases. The first line of input contains an integer
T(T <= 100), indicating the number of test cases. Then T test cases follow.

Each test case contains two lines: The first line of each test case contains only one integerN, indicating the number of bidders. (2 <=
N <= 100) The second line of each test case containsN integers separated by a space. The
i-th integer Pi indicates thei-th bidder's bid. (0 <
Pi <= 60000) You may assume that the highest bid is unique.

Output

For each test case, output a line containing two integers x and y separated by a space. It indicates that thex-th bidder is the winner and the amount of money he (or she) should pay isy.

Sample Input

2
3
3 2 1
2
4 9


Sample Output

1 2
2 4


#include<stdio.h>
#include<algorithm>
using namespace std;
int z[1007];
int cmp(int a1,int b1)
{
return a1>b1;
}
int main()
{
int m;
while(scanf("%d",&m)!=EOF)
{
while(m--)
{
int n;
scanf("%d",&n);
for(int a=0;a<n;a++)
scanf("%d",&z[a]);
int max=z[0],flag=0;
for(int  b=0;b<n;b++)
if(z[b]>max){max=z[b],flag=b;}
sort(z,z+n,cmp);
printf("%d %d\n",flag+1,z[1]);

}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: