您的位置:首页 > 其它

POJ3020——Antenna Placement(二分图最大匹配)

2013-03-20 22:03 453 查看
Antenna Placement
Time Limit: 1000MS

Memory Limit: 65536K
Total Submissions: 5144
Accepted: 2568
Description
The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and
comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating
in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 

 

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest,
which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r),
or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing
the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2

7 9

ooo**oooo

**oo*ooo*

o*oo**o**

ooooooooo

*******oo

o*o*oo*oo

*******oo

10 1

*

*

*

o

*

*

*

*

*

*

Sample Output

17

5

Source
Svenskt Mästerskap i Programmering/Norgesmesterskapet 2001

解析:

          不难看出这是一道关于无向二分图的最小路径覆盖。。。

          至于最小路径覆盖。。即在二分图中找出最少的边来覆盖所有点。。。由此可确定基本算法:求二分图最大匹配数,再根据公式:最小路径覆盖=定点数-最大匹配数/2;

          接下来最关键的就是如何建图。。。

          由于基站可覆盖相邻的两个城市,可以在这两个城市之间连一条边。。。即二分图两个集合分别为所有点。。。

          读入数据时累加顶点编号,拆点(顺便完成)。。。与上下左右连边。。。

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int test,ip,ret,n,m;
char op;
int pic[410][410],map[49][50],pre[410];
bool vis[401];

bool check(int u)
{
for(int i=1;i<=ip;i++)
{
if(pic[u][i] && !vis[i])
{
vis[i]=1;
if(pre[i]==-1 || check(pre[i]))
{
pre[i]=u;
return 1;
}
}
}
return 0;
}

void match()
{
for(int i=1;i<=ip;i++)
{
memset(vis,0,sizeof(vis));
if(check(i))ret++;
}
}

void readdata()
{
freopen("poj3020.in","r",stdin);
freopen("poj3020.out","w",stdout);
scanf("%d",&test);
while(test--)
{
ret=0;ip=0;
memset(pre,255,sizeof(pre));
memset(map,0,sizeof(map));
memset(pic,0,sizeof(pic));
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
{
cin>>op;
if(op=='*')map[i][j]=++ip; //累加点的编号
}
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
{
if(map[i][j]) //如果该点为'*',找附近的'*'并连边。。。
{
if(map[i][j+1])pic[map[i][j+1]][map[i][j]]=1;
if(map[i][j-1])pic[map[i][j-1]][map[i][j]]=1;
if(map[i+1][j])pic[map[i+1][j]][map[i][j]]=1;
if(map[i-1][j])pic[map[i-1][j]][map[i][j]]=1;
}
}
match();             //最大匹配。。。
printf("%d\n",ip-ret/2);
}
}

int main()
{
readdata();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: