您的位置:首页 > 其它

POJ 2774 Long Long Message (后缀数组)

2013-03-15 20:21 281 查看
Long Long Message
Time Limit: 4000MSMemory Limit: 131072K
Total Submissions: 16819Accepted: 6828
Case Time Limit: 1000MS
DescriptionThe little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother.The little cat lives in an unrich family, so he frequently comes to
the mobile service center, to check how much money he has spent on SMS.
Yesterday, the computer of service center was broken, and printed two
very long messages. The brilliant little cat soon found out:1. All characters in messages are lowercase Latin letters, without punctuations and spaces.2. All SMS has been appended to each other – (i+1)-th SMS comes
directly after the i-th one – that is why those two messages are quite
long.3. His own SMS has been appended together, but possibly a great many
redundancy characters appear leftwards and rightwards due to the broken
computer.E.g: if his SMS is “motheriloveyou”, either long message printed by
that machine, would possibly be one of “hahamotheriloveyou”,
“motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”,
etc.4. For these broken issues, the little cat has printed his original
text twice (so there appears two very long messages). Even though the
original text remains the same in two printed messages, the redundancy
characters on both sides would be possibly different.You are given those two very long messages, and you have to output
the length of the longest possible original text written by the little
cat.Background:The SMS in Byterland mobile service are charging in
dollars-per-byte. That is why the little cat is worrying about how long
could the longest original text be.Why ask you to write a program? There are four resions:1. The little cat is so busy these days with physics lessons;2. The little cat wants to keep what he said to his mother seceret;3. POJ is such a great Online Judge;4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :(InputTwo
strings with lowercase letters on two of the input lines individually.
Number of characters in each one will never exceed 100000.
OutputA single line with a single integer number – what is the maximum length of the original text written by the little cat.
Sample Input
yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output
27
思路:最长公共字串,论文上有,只需找出最大值即可
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
using namespace std;

const int maxn=200020;
char s[maxn];
int r[maxn],rank[maxn],wa[maxn],wb[maxn],wss[maxn],wv[maxn],h[maxn],sa[maxn];
int n,m,l,ans;

void close()
{
exit(0);
}
int cmp(int *r,int a,int b,int l)
{
return (r[a]==r[b] && r[a+l]==r[b+l]);
}
void da(int m,int *ws)
{
int i,j,p,*x=wa,*y=wb,*t;
for (i=0;i<m;i++) ws[i]=0;
for (i=0;i<n;i++) ws[x[i]=r[i]]++;
for (i=1;i<m;i++) ws[i]+=ws[i-1];
for (i=n-1;i>=0;i--) sa[--ws[r[i]]]=i;
for (j=1,p=1;p<n;j*=2,m=p)
{
for (p=0,i=n-j;i<n;i++) y[p++]=i;
for (i=0;i<n;i++) if (sa[i]>=j) y[p++]=sa[i]-j;
for (i=0;i<n;i++) wv[i]=x[y[i]];
for (i=0;i<m;i++) ws[i]=0;
for (i=0;i<n;i++) ws[wv[i]]++;
for (i=1;i<m;i++) ws[i]+=ws[i-1];
for (i=n-1;i>=0;i--) sa[--ws[wv[i]]]=y[i];
for (t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
}
}

void callheight(int n)
{
int i,j,k=0;
for (i=1;i<=n;i++) rank[sa[i]]=i;
for (i=0;i<n;h[rank[i++]]=k)
for (k?k--:0,j=sa[rank[i]-1];r[i+k]==r[j+k];k++);
}

void init()
{
//freopen("lcs.out","w",stdout);
m=0;
scanf("%s",s);
s[l=strlen(s)]=1;
int rec=l;
scanf("%s",s+l+1);
l=strlen(s);
for (int i=0;i<l;i++)
{
r[i]=s[i];
if (r[i]>m)
m=r[i];
}
r[l]=0;
n=l;
da(m+1,wss);
callheight(n-1);
ans=0;
for (int i=1;i<=n-2;i++)
{
bool flag=false;
if (sa[i]<rec && sa[i+1]<rec)
flag=true;
if (sa[i]>rec && sa[i+1]>rec)
flag=true;
if (not flag)
{
if (h[i+1]>ans)
ans=h[i+1];
}
}
printf("%d\n",ans);
}
int main ()
{
init();
close();
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: