您的位置:首页 > 大数据 > 人工智能

HDU1789:Doing Homework again

2013-03-14 20:47 232 查看
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.


Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.



Output
For each test case, you should output the smallest total reduced score, one line per test case.



Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4




Sample Output
0
3
5






#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

struct Node
{
    int time,fen;
} node[1005];

int cmp(struct Node a,struct Node b)
{
    if(a.fen!=b.fen)
        return a.fen > b.fen;//扣分越多的越靠前
    return a.time < b.time;//扣分相同的时候,deadline越早的越靠前
}

int  visit[2010];//如果当天没用过,值为0;否则为1

int main()
{
    int m;
    cin >> m;
    while(m--)
    {
        int n,i,j,ans = 0;
        memset(visit,0,sizeof(visit));
        cin >> n;
        for(i = 0; i<n; i++)
        {
            cin >> node[i].time;
        }
        for(i = 0; i<n; i++)
        {
            cin >> node[i].fen;
        }
        sort(node,node+n,cmp);
        int sum = 0;
        for(i=0; i<n; i++)
        {
            j=node[i].time;// 从截止时间开始往前推,如果有一天没用过,这一天就做这一门课,这门课不扣分
            while(j)
            {
                if(!visit[j])
                {
                    visit[j]=1;
                    break;
                }
                j--;
            }
            if(j==0)//如果j=0,表明从time往前的每一天都被占用了,这门课完不成
                ans+=node[i].fen;
        }
        cout << ans << endl;
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: