您的位置:首页 > 其它

poj 1703 Find them, Catch them(并查集应用)

2013-03-14 11:08 459 查看
Find them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 23593Accepted: 7066
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

思路:把能确定关系的存在一个集合之中,用kind来代表不同的帮派
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int mm=1e5+9;
int root[mm],kind[mm];
int n,m;
void data()
{
for(int i=0;i<=n;i++)
root[i]=i,kind[i]=0;
}
int look(int x)
{ int z;
if(x^root[x])
{ z=root[x];
root[x]=look(root[x]);
kind[x]=(kind[x]+kind[z])%2;
}
return root[x];
}
void uni(int ra,int rb,int a,int b)
{
root[ra]=rb;kind[ra]=(kind[a]-kind[b]+1)%2;
}
int main()
{
int cas;
char s;
scanf("%d",&cas);
while(cas--)
{
scanf("%d%d",&n,&m);
data();int a,b,ra,rb;
for(int i=0;i<m;i++)
{ while((s=getchar())&&(s!='A'&&s!='D'));
///cin>>s>>a>>b;
scanf("%d%d",&a,&b);
ra=look(a);rb=look(b);
if(s=='A')
{
if(ra^rb)printf("Not sure yet.\n");
else if(kind[a]==kind[b])printf("In the same gang.\n");
else printf("In different gangs.\n");
}
else
{
if(ra^rb)
uni(ra,rb,a,b);
}
}
}
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: