您的位置:首页 > 其它

UVaOJ101---The Blocks Problem

2013-03-13 22:03 281 查看



[title3]
101 - The Blocks Problem[/title3]

Time limit: 3.000 seconds

Background

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm
performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of
commands.

The Problem

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks
on the table (numbered from 0 to n-1) with block bi adjacent
to block bi+1 for all

as
shown in the diagram below:


Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions
prior to the pile taking place. The blocks stacked above block a retain their order when moved.

pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block aretain
their original order when moved.

quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration
of blocks.

The Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0
< n < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.
You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output

The output should consist of the final state of the blocks world. Each original block position numbered i (

where n is
the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other
block numbers by a space. Don't put any trailing spaces on a line.
There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit


Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:


解题思路:使用双向链表

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int LIMITS = 100;
struct Node
{
Node *pred;
int val;
Node *rear;
};

int n;
int a, b;
char commond[100];
char first_word[100];
char second_word[100];
Node *head[LIMITS];
Node *block[LIMITS];
int pos[LIMITS];

void Init()
{
for (int i = 0; i < n; i ++)
{
head[i] = new Node;
block[i] = new Node;
head[i]->pred = NULL;
head[i]->val = -1;
head[i]->rear = block[i];
block[i]->pred = head[i];
block[i]->val = i;
block[i]->rear = NULL;
pos[i] = i;
}
}
void ReturnOriginalPos(Node *p)
{
if (p == NULL)
{
return;
}
ReturnOriginalPos(p->rear);
p->pred = head[p->val];
p->rear = NULL;
head[p->val]->rear = p;
pos[p->val] = p->val;
}
void Connect(Node *a, Node *b)
{
a->pred->rear = NULL;
a->pred = b;
b->rear = a;
pos[a->val] = pos[b->val];
}
void MoveAOntoB(Node *a, Node *b)
{
ReturnOriginalPos(a->rear);
ReturnOriginalPos(b->rear);
a->rear = NULL;
Connect(a, b);
}
void MoveAOverB(Node *a, Node *b)
{
ReturnOriginalPos(a->rear);
a->rear = NULL;
Node *b_tail = b;
while (b_tail->rear != NULL)
{
b_tail = b_tail->rear;
}
Connect(a, b_tail);
}
void PileAOntoB(Node *a, Node *b)
{
ReturnOriginalPos(b->rear);
Connect(a, b);
Node *p = a->rear;
while (p != NULL)
{
pos[p->val] = pos[b->val];
p = p->rear;
}
}
void PileAOverB(Node *a, Node *b)
{
Node *b_tail = b;
while (b_tail->rear != NULL)
{
b_tail = b_tail->rear;
}
Connect(a, b_tail);
Node *p = a->rear;
while (p != NULL)
{
pos[p->val] = pos[b->val];
p = p->rear;
}
}
void Output()
{
for (int i = 0; i < n; i ++)
{
cout<<i<<":";
Node *p = head[i]->rear;
while (p != NULL)
{
cout<<" "<<p->val;
p = p->rear;
}
cout<<endl;
}
}
int main()
{
while (cin>>n)
{
getchar();
Init();
while (cin>>first_word)
{
if (strcmp(first_word, "quit") == 0)
{
break;
}
//          cin>>commond;
//          sscanf(commond, "%d%s%d", &a, second_word, &b);
cin>>a>>second_word>>b;
if (pos[a] != pos[b])
{
if (strcmp(first_word, "move") == 0)
{
if (strcmp(second_word, "onto") == 0)
{
MoveAOntoB(block[a], block[b]);
}
if (strcmp(second_word, "over") == 0)
{
MoveAOverB(block[a], block[b]);
}
}
if (strcmp(first_word, "pile") == 0)
{
if (strcmp(second_word, "onto") == 0)
{
PileAOntoB(block[a], block[b]);
}
if (strcmp(second_word, "over") == 0)
{
PileAOverB(block[a], block[b]);
}
}
}
}
Output();
for (int i = 0; i < n; i++)
{
delete head[i];
delete block[i];
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: