您的位置:首页 > 其它

hdu 1061 Rightmost Digit

2013-03-13 08:40 483 查看

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22887 Accepted Submission(s): 8739


[align=left]Problem Description[/align]
Given a positive integer N, you should output the most right digit of N^N.

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

[align=left]Output[/align]
For each test case, you should output the rightmost digit of N^N.

[align=left]Sample Input[/align]

2
3
4

[align=left]Sample Output[/align]

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
using namespace std;
int main(void){
#ifndef ONLINE_JUDGE
freopen("1061.in", "r", stdin);
#endif
int t; long long n;
while (~scanf("%d", &t))
while (t--){
scanf("%lld", &n);
int m = n % 10, l = n % 4 + 4, s = m;
for (int i = 1; i < l; ++i) s *= m;
printf("%d\n", s%10);
}
return 0;
}


这道题目还是很困惑,为什么说多test cases 还要加 while (~scanf("%d", &t)) 这句话?难道是每一个test case 又有多个cases?

因为这个原因卡了很久……次嗷……
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: