您的位置:首页 > 其它

HDOJ_ACM_Pie

2013-03-10 15:34 225 查看
[align=left]Problem Description[/align]
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

[align=left]Input[/align]
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

[align=left]Output[/align]
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

[align=left]Sample Input[/align]

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2


[align=left]Sample Output[/align]

25.1327
3.1416
50.2655


[align=left]Codes[/align]

#include <stdio.h>
#include <math.h>
#define N 10000
#define PI acos(-1.0)
int n, f;
int ri[N + 5];
double v[N + 5];
//参数是体积,判断该体积下,可以分到蛋糕的人数是否大于等于指定人数
//parameter: volume
//function: judge if the all the people get the cake in the case of the volume
int isSuitable(double vol)
{
int num, i;
num = 0;
for (i = 1; i <= n; i++)
{
num += (int)(v[i] / vol);
}
if (num < f)
return 0;
else
return 1;
}
void main()
{
//declare
int i, j, count;
double min, max, mid, sum, res;
sum = 0;
scanf("%d", &count);
for (j = 1; j <= count; j++)
{
//input  输入
scanf("%d %d", &n, &f);
for (i = 1; i <= n; i++)
{
scanf("%d", &ri[i]);
v[i] = ri[i] * ri[i];
sum += v[i];
}
//dichotomy 二分法--------------------
f += 1;
min = 0;
max = sum / f;
//如果最大值都满足条件,那么就答案就是这个最大值
//firstly, judge if the max is suitable
if (isSuitable(max))
res = max;
else
{
//find the the result by using dictomoy
while (max - min > 1e-6)
{
mid = (max + min) / 2;
if (isSuitable(mid))
min = mid;
else
max = mid;
}
}
//output
printf("%.4f\n", min * PI);
}
}


[align=left]Key Points[/align]
Firstly, in order to gain high precision, we must use "acos(-1.0)", which need add "#include <math.h>" instand of "3.1415926", and write "1e-6" instand of "1e-5".
Secondly, there is no "bool" in C, but there is in C++.

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: