您的位置:首页 > 编程语言 > C语言/C++

习题 ct6_1: 循环移位☆

2013-03-09 22:27 190 查看
[mytable=ct6_1: 循环移位☆]题目描述:

给你一个字符串"abcdefg",循环左移两位得到"cdefgab",

循环右移两位得到"fgabcde"

输入:

多组测试数据,每组一行,第一个是int范围内的整数n,

表示要右移的位数,如果n是负数则表示要左移。接着后面

是一个串长小于10000000的字符串。

最后遇到EOF标志的时候结束。

输出:

输出移位后的字符串

样例输入:

2 abcdefg

-2 abcdefg

样例输出:

fgabcde

cdefgab

难度:for beginner[/mytable]

// ct6_1.cpp : Defines the entry point for the console application.
//

#include "stdafx.h"
#include "stdio.h"
#include "string.h"

int main(int argc, char* argv[])
{
char str[100];
int pos, i, length;
while( scanf("%d%s", &pos, str) != EOF)
{
length = strlen(str);
if (pos > 0)
{
if (pos % length == 0) { printf("%s\n", str); continue;}
for (i= length-pos; i<=length-1; i++ )
{
printf("%c",str[i]);
}
for (i= 0; i<=length-pos-1; i++ )
{
printf("%c",str[i]);
}
continue;
}
else if (pos < 0)
{
pos = -1 * pos;
if (pos % length == 0) { printf("%s\n", str); continue;}
for (i= pos; i<=length-1; i++ )
{
printf("%c",str[i]);
}
for (i= 0; i<=pos-1; i++ )
{
printf("%c",str[i]);
}
continue;
}
else
{
printf("%s\n", str);
continue;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 vc++6.0