您的位置:首页 > 其它

UVA 725 - Division

2013-03-07 17:15 429 查看
Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal
to an integer N, where 

. That is,

abcde / fghij = N
where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer N. An input
of zero is to terminate the program.

Output 

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).
Your output should be in the following general form:

xxxxx / xxxxx = N
xxxxx / xxxxx = N
.
.

In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.

Sample Input 

61
62
0


Sample Output 

There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62


#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype>
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 1000

bool check(int a, int b){
int repeat[11] = {0};

if(a < 10000){
repeat[0]++;
}
if(b < 10000){
repeat[0]++;
}

if(repeat[0] > 1){
return false;
}

while(a != 0){
int remain = a % 10;
if(repeat[remain] != 0){
return false;
}
repeat[remain]++;
a /= 10;
}

while(b != 0){
int remain = b % 10;
if(repeat[remain] != 0){
return false;
}
repeat[remain]++;
b /= 10;
}

return true;
}

void play(int n){

int fghij = 1234;
int abcde = n * fghij;

bool found = false;
for(; abcde<100000; ++fghij){
abcde = n * fghij;
if(check(abcde, fghij)){
found = true;
//自动补零
printf("%05d / %05d = %d\n", abcde, fghij, n);
}
}

if(!found){
printf("There are no solutions for %d.\n", n);
}
}

int main(){

#ifndef ONLINE_JUDGE
freopen("725.in", "r", stdin);
freopen("725.out", "w", stdout);
#endif

int n;

// 有用的技巧来避免结尾多输出一空行
bool blank = false;

while(scanf("%d",&n)==1 && n){
if(blank){
printf("\n");
}
play(n);
blank = true;
}

}

#endif
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: