您的位置:首页 > 其它

POJ 2909

2013-03-07 17:00 113 查看
Goldbach's Conjecture

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9166Accepted: 5341
Description

For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that

n = p1 + p2
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number
of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore
you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input
6
10
12
0

Sample Output
1
2
1

Source

Svenskt Mästerskap i Programmering/Norgesmesterskapet 2002

最初的想法是:把所有的质数找出来,然后在数组里面查找

复杂度是O(n)+O(logN * log N)

//tju 1859 (tju1171-2262poj)
//poj 2909
#include<iostream>
#include<math.h>
#define MAX 32768
using namespace std;
int Primer[MAX];

bool isPrimer(int n){
int i = 0;
for(i = 3; i <= sqrt((long double)n);i = i+2){
if(n%i == 0)
return false;
}
return true;
}
int BiSearch(int key,int length){
int lo = 0, hi = length-1;
int mid = (lo + hi)/2;
while(lo<=hi){
mid = (lo + hi)/2;
if(key < Primer[mid]){
hi = mid -1;
//cout<<"less"<<endl;
//cout<<Primer[mid]<<endl;
continue;
}
else if(key > Primer[mid])
{
lo = mid +1;
//cout<<"larger"<<endl;
continue;
}
else
return mid;
}
return mid;
}

int main(){
int n=0;
Primer[0] =2;
int i,pi = 1;

for(i=3;i<MAX;i=i+2)
{
if(isPrimer(i)){
Primer[pi]=i;
//cout<<i<<endl;
pi++;
}
//if(i>10)
// break;
}
//cout<<Primer[1257]<<endl;
//cout<<BiSearch(2,5)<<endl;
//cout<<pi<<endl;
while(cin>>n){
if(n==0)
break;
int pairs = 0;
int p_smaller = 0;
int smaller = 0;
int p_bigger = 0;
int bigger = 0;
//cout<<pi<<n<<endl;
int MaxSearcherNum =  BiSearch(n,pi+1);
//cout<<MaxSearcherNum<<endl;

for(p_smaller = 0;p_smaller<MaxSearcherNum/2+1;p_smaller++){
//cout<<"p_smaller = "<< p_smaller<< endl;
smaller = Primer[p_smaller];
bigger = n - smaller;
//cout<<BiSearch(bigger,MaxSearcherNum)<<endl;
if(Primer[BiSearch(bigger,MaxSearcherNum)]==bigger){
//cout<<n<<" = "<<smaller<<" + "<< bigger<<endl;
pairs ++;

}
}
cout<< pairs <<endl;

}
system("pause");
return 0;
}


小插曲:二分查找while循环里面没有赋值mid,耗时很久

但是后来超时想试一试,最简单的想法
//tju 1859 (tju1171-2262poj)
//poj 2909
#include<iostream>
#include<math.h>
#define MAX 32768
using namespace std;
int Primer[MAX];

bool isPrimer(int n){
int i = 0;
for(i = 3; i <= sqrt((long double)n);i = i+2){
if(n%i == 0)
return false;
}
return true;
}
int BiSearch(int key,int length){
int lo = 0, hi = length-1;
int mid = (lo + hi)/2;
while(lo<=hi){
mid = (lo + hi)/2;
if(key < Primer[mid]){
hi = mid -1;
//cout<<"less"<<endl;
//cout<<Primer[mid]<<endl;
continue;
}
else if(key > Primer[mid])
{
lo = mid +1;
//cout<<"larger"<<endl;
continue;
}
else
return mid;
}
return mid;
}
int main(){
int n;
while(cin>>n){
if(n==0)
break;
int i = 0;
int pairs = 0;

//cout<<pairs<<endl;
for(i=3;i<n/2+1;i=i+2){
int temp = n - i;
if(isPrimer(temp)&&isPrimer(i)){
//cout<< temp<<" "<<i<<endl;
pairs++;
}
}
cout<<pairs<<endl;
}
return 0;
}


但是时间还是不行。。

最后找人要来的他的想法,是把位置看成数,把内容表示成bool,这样在查找时候就可以互补对调,看0,1来觉得要不要这一对,时间是O(n)+O(n)

#include <iostream>
#include <math.h>
#include <string.h>
using namespace std;

int main()
{
int N;

bool isprim[33000];
memset(isprim, 1, 33000);
int temq = (int)sqrt((double)(33000));

for(int i = 2; i <= temq; i++)
{
if(isprim[i] == false)
continue;

for(int j = i * i; j < 33000; j += i)
{
isprim[j] = false;
}
}

isprim[0] = isprim[1] = isprim[2] = false;
//for(int i = 3; i < 33; i++)
//{
//	if(isprim[i] == true)
//	{
//		cout<<i<<endl;
//	}
//}

while(cin>>N)
{
if(N == 0)
break;

int hN = N /2;

int total = 0;
for(int i = 3; i <= hN; i++ )
{
if(isprim[i] == true)
{
if(isprim[N - i] == true)
{
total++;
}
}
}

cout<<total<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: