您的位置:首页 > 大数据 > 人工智能

hdu 1022 Train Problem I

2013-03-06 22:55 441 查看
题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1022

题目描述:

Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13332 Accepted Submission(s): 4900



[align=left]Problem Description[/align]
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.







[align=left]Input[/align]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file.
More details in the Sample Input.

[align=left]Output[/align]
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out"
for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

[align=left]Sample Input[/align]

3 123 321
3 123 312


[align=left]Sample Output[/align]

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".


题意:给定火车的进站排队顺序 和 出站顺序 给出由进站顺序 生成相应的策略。

题解:模拟,两个指针分别扫描两个序列,从出站顺序的情况来决定 进站的操作是 push 还是 pop。

代码:

/*
hdu:Train Problem I
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int Trains=0;
char O1[10+5]={'\0'},O2[10+5]={'\0'};
int Operations[20+5]={0};//0 -> no ops ; 1 -> push ; -1->pop
int Stacks[10+5]={0},top=-1;//top point stack's top has a value usually

/*initialize the var*/
int InitVar()
{
//memset only use to char array
int i=0;
for(i=0;i<=20+5-1;i++)
{
Operations[i]=0;
}
return(0);
}

/*for test*/
int test()
{
return(0);
}

/*main process*/
int MainProc()
{
while(scanf("%d%s%s",&Trains,O1,O2)!=EOF)
{
InitVar();
top=-1;
bool Flag=true;
int i=0,j=0,t=0;//pointer for the two stirngs
for(j=0;j<=Trains-1;j++)
{
//for(;i<=Trains;i++)//maybe a bug  the i++ and i<=Ttrains-1
//{
if(top>=0&&Stacks[top]==O2[j])
{
;
}
else
{
for(;i<=Trains-1;i++)
{
if(O1[i]!=O2[j])
{
Operations[t++]=1;// t-1 is the end
Stacks[++top]=O1[i];//push
}
else
{
Operations[t++]=1;
Stacks[++top]=O1[i];
i++;
break;
}
}
}
//}
if(Stacks[top]==O2[j])
{
Operations[t++]=-1;
top--;//pop
}
else
{
Flag=false;
break;
}
}
if(Flag)
{
printf("Yes.\n");
for(i=0;i<=t-1;i++)
{
if(Operations[i]>0)
{
printf("in\n");
}
else
{
printf("out\n");
}
Operations[i]=0;//clear the side effect
}
}
else
{
printf("No.\n");
}
printf("FINISH\n");
}
return(0);
}

int main()
{
MainProc();
return(0);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: