您的位置:首页 > 其它

hdu 1124 Factorial

2013-03-03 22:21 423 查看
题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1124

题目描述:

Factorial

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1955 Accepted Submission(s): 1250



[align=left]Problem Description[/align]
The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest
signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying
this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and
it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high
even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour
of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1<N2, then Z(N1) <= Z(N2). It is because
we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.

[align=left]Input[/align]
There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

[align=left]Output[/align]
For every number N, output a single line containing the single non-negative integer Z(N).

[align=left]Sample Input[/align]

6
3
60
100
1024
23456
8735373


[align=left]Sample Output[/align]

0
14
24
253
58612183837


题意:求N的阶乘出来的结果尾部有多少个连续的零。

题解:假设N!= M x 10^n 即问题即是 给出N的值 求出n的值。这里知道10=2 x 5的 而N!= 2^a + 3^b + 5^c + 7^d +...... 即所有的素数幂次和可以组成N!,那么2^a+5^b=(2 x 5)^t; 即求t的值,由于2<5 那么a〉b的 即 问题转化为求N!中5这个素数因子的个数。而N!=1 x 2 x 3 x 4 x 5 x.....x N; 这里每5个因子便会至少出现一次5

如1 x 2 x 3 x 4 x 5 6x7x8x9x10 11x12x13x14x15 16x17x18x19x20 21x22x23x24x25 这里不难发现这样的规律,那么N/5 便是N!中第一遍出现的5,有第一遍那么

就还有第二遍,如21x22x23x24x25中的25 实际上它是由两个5的因子5x5,这样可以总结为每5个因子的5个因子会出现第二个5,即1x2x3x4x5作为一个因子,这样每隔5个

又会出现第二遍的5因子即5x5中的后面的那个5因子 以此类推125 就是第三遍了,这种5因子的不同遍数的出现时叠加的,其中第一遍的5因子贯穿所有乘数,而第二遍5

因子在25出现之后才开始连续出现 第三遍5因子在125出现之后才开始出现,由于具有这样的迭代属性(或者说是嵌套),那么我们将N不断地除以5 , 然后再用除数除以5(这就是嵌套的5因子所在),除到不能除为止,然后把这些除数累加就是N!所有5因子的总数了,显然第一次除以5留下来的除数就是第一遍5因子的个数了,以此类推。

相当于 N!中5因子的个数=N!/5+N!/25+N!/125+N!/5^4+.......N!/5^n=N不断地用除以5得来的除数除以5;

代码:

/*
hdu : Factorial

divide the quality factor and find the number of the 5 factor,nest interval 5

*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>

using namespace std;

int N=0,T=0,Cnt=0;

/*initialize the var*/
int InitVar()
{
Cnt=0;
return(0);
}

/*for test*/
int test()
{
return(0);
}

/*main process*/
int MainProc()
{
scanf("%d",&T);
while(T--)
{
InitVar();
scanf("%d",&N);
while(N)
{
N/=5;
Cnt+=N;
}
printf("%d\n",Cnt);
}
return(0);
}

int main()
{
MainProc();
return(0);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: