您的位置:首页 > 其它

hdu 1856 More is better(并查集)

2013-03-03 20:27 453 查看


More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 8057 Accepted Submission(s): 3001



Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


Sample Output

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.


Author

lxlcrystal@TJU

Source

HDU 2007 Programming Contest - Final

Recommend

lcy

思路:并查集,简单把是朋友的都合并就好了。注意0的情况。

#include<iostream>
#include<cstring>
using namespace std;
const int mm=1e7+9;
int root[mm],ran[mm];
int n,a,b,ans;
int look(int x)
{
if(x^root[x])root[x]=look(root[x]);
return root[x];
}
void data_set()
{
for(int i=0;i<mm;i++)
root[i]=i,ran[i]=1;
}
void uni(int x,int y)
{
x=look(x);y=look(y);
if(x==y)return;
if(ran[x]>ran[y])root[y]=x,ran[x]+=ran[y];
else root[x]=y,ran[y]+=ran[x];
if(ans<ran[x])ans=ran[x];
if(ans<ran[y])ans=ran[y];
}
int main()
{
while(cin>>n)
{ data_set();ans=0;
for(int i=0;i<n;i++)
{
cin>>a>>b;
if(a^b)
uni(a,b);
}
if(n==0)ans=1;
cout<<ans<<"\n";

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: