您的位置:首页 > 其它

UVA 455 - Periodic Strings

2013-03-03 03:08 295 查看
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc"
has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string
of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2


#define RUN
#ifdef RUN

#include <stdio.h>
#include <string.h>

int main() {

#ifndef ONLINE_JUDGE
freopen("455.in", "r", stdin);
freopen("455.out", "w", stdout);
#endif

int n;
char word[100];

scanf("%d", &n);
getchar();

for(int k=0; k<n; k++){
getchar();
memset(word, 0, sizeof(word));
scanf("%s", word);
int len = strlen(word);
for (int i = 1; i <= len; i++){
if (len % i == 0) { // 符合条件的必能被i整除
int ok = 1;
for (int j = i; j < len; j++){
if (word[j] != word[j % i]){
ok = 0;
break;
}
}
if (ok) {
printf("%d\n", i);
break;
}
}
}
if(k != n-1){
printf("\n");
}

}

return 0;
}

#endif
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: