您的位置:首页 > 其它

hdu1880之魔咒词典

2013-03-02 22:10 387 查看
Problem Description

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”



Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。

词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。



Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”



Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky




Sample Output

light the wand
accio
what?
what?
题目挺简单的,但是处理细节问题花了好多时间
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=100001;
map<string,string>a;
map<string,string>b;

int main(){
	string z,t;
	string tmp, word, meaning;
	getline(cin, tmp);
	while (tmp != "@END@")
	{
		string::size_type idx = tmp.find(']');
		word = tmp.substr(0, idx + 1);
		meaning = tmp.substr(idx + 2, tmp.size() - idx - 2);
		a.insert(make_pair(word, meaning));
		b.insert(make_pair(meaning, word));
		getline(cin, tmp);
	}
	int n;
	cin>>n;
	getline(cin,z);
	for(int i=0;i<n;++i){
		getline(cin,z);
		if(z[0] == '['){
			if(a[z] != "\0"){cout<<a[z];}
			else printf("what?");
		}
		else{
			if(b[z] != "\0"){t=b[z];t=t.substr(1,t.size()-2);cout<<t;}
			else printf("what?");
		}
		cout<<endl;
	}
	return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: