您的位置:首页 > 其它

POJ 1949 Chores(树状DP)

2013-03-02 18:26 387 查看
Chores

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 4516 Accepted: 2114
Description

Farmer John's family pitches in with the chores during milking, doing all the chores as quickly as possible. At FJ's house, some chores cannot be started until others have been completed, e.g., it is impossible to wash the cows until they are in the stalls. 

Farmer John has a list of N (3 <= N <= 10,000) chores that must be completed. Each chore requires an integer time (1 <= length of time <= 100) to complete and there may be other chores that must be completed before this chore is started. We will call these
prerequisite chores. At least one chore has no prerequisite: the very first one, number 1. Farmer John's list of chores is nicely ordered, and chore K (K > 1) can have only chores 1,.K-1 as prerequisites. Write a program that reads a list of chores from 1
to N with associated times and all perquisite chores. Now calculate the shortest time it will take to complete all N chores. Of course, chores that do not depend on each other can be performed simultaneously.
Input

* Line 1: One integer, N 

* Lines 2..N+1: N lines, each with several space-separated integers. Line 2 contains chore 1; line 3 contains chore 2, and so on. Each line contains the length of time to complete the chore, the number of the prerequisites, Pi, (0 <= Pi <= 100), and the Pi
prerequisites (range 1..N, of course). 

Output

A single line with an integer which is the least amount of time required to perform all the chores. 

Sample Input
7
5 0
1 1 1
3 1 2
6 1 1
1 2 2 4
8 2 2 4
4 3 3 5 6

Sample Output
23

Hint

[Here is one task schedule:

Chore 1 starts at time 0, ends at time 5.

Chore 2 starts at time 5, ends at time 6.

Chore 3 starts at time 6, ends at time 9.

Chore 4 starts at time 5, ends at time 11.

Chore 5 starts at time 11, ends at time 12.

Chore 6 starts at time 11, ends at time 19.

Chore 7 starts at time 19, ends at time 23.

]


Source

USACO 2002 February

本来是想用最短路算法求最长路来写的,发现一直WA,然后改用树状DP来写就过了....不知何解....树状DP写的话还是比较简单的

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int oo=10000000;
int pre[10005][105];
int dp[10005],n;
int cost[10005],cnt[10005];
inline int max(int a,int b)
{
return a>b?a:b;
}
void treedp(int now)
{
for(int i=0;i<cnt[now];++i)
if(dp[pre[now][i]]==oo) treedp(pre[now][i]);
int res=0;
for(int i=0;i<cnt[now];++i)
res=max(dp[pre[now][i]],res);
dp[now]=res+cost[now];
return;
}
int main()
{
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
{
dp[i]=oo;
scanf("%d%d",&cost[i],&cnt[i]);
if(cnt[i]==0) dp[i]=cost[i];
for(int j=0;j<cnt[i];++j)
scanf("%d",&pre[i][j]);
}
int ans=-1;
for(int i=1;i<=n;i++)
{
treedp(i);
ans=max(ans,dp[i]);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: