您的位置:首页 > 其它

poj 2570 Fiber Network(最短路+Floyd)

2013-02-28 16:47 337 查看
Fiber Network

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 2611Accepted: 1195
Description

Several startup companies have decided to build a better Internet, called the "FiberNet". They have already installed many nodes that act as routers all around the world. Unfortunately, they started to quarrel about the connecting lines, and ended up with every
company laying its own set of cables between some of the nodes.

Now, service providers, who want to send data from node A to node B are curious, which company is able to provide the necessary connections. Help the providers by answering their queries.
Input

The input contains several test cases. Each test case starts with the number of nodes of the network n. Input is terminated by n=0. Otherwise, 1<=n<=200. Nodes have the numbers 1, ..., n. Then follows a list of connections. Every connection starts with two
numbers A, B. The list of connections is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the unidirectional connection, respectively. For every connection, the two nodes are followed by the companies that have a connection
from node A to node B. A company is identified by a lower-case letter. The set of companies having a connection is just a word composed of lower-case letters.

After the list of connections, each test case is completed by a list of queries. Each query consists of two numbers A, B. The list (and with it the test case) is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the query.
You may assume that no connection and no query contains identical start and end nodes.
Output

For each query in every test case generate a line containing the identifiers of all the companies, that can route data packages on their own connections from the start node to the end node of the query. If there are no companies, output "-" instead. Output
a blank line after each test case.


Sample Input
3
1 2 abc
2 3 ad
1 3 b
3 1 de
0 0
1 3
2 1
3 2
0 0
2
1 2 z
0 0
1 2
2 1
0 0
0

Sample Output
ab
d
-

z
-

Source

Ulm Local 2001

思路:变种最短路,floyd。用二进制压缩存不同的公司。

#include<iostream>
#include<cstring>
using namespace std;
const int mm=210;
int g[mm][mm];
int n;
char s[mm];
int main()
{
int a,b;
while(cin>>n&&n)
{ memset(g,0,sizeof(g));
while(cin>>a>>b)
{if(a==0&&b==0)break;
a--;b--;cin>>s;
g[a][b]=0;
for(int i=0;s[i];i++)
{
g[a][b]|=1<<(s[i]-'a');
}
}
for(int k=0;k<n;k++)
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(i^k&&j^k)
g[i][j]|=g[i][k]&g[k][j];
while(cin>>a>>b)
{
if(a==0&&b==0)break;
--a;--b;
if(g[a][b])
{ int z=g[a][b],k=0;
while(z)
{
if(z&1)cout<<char('a'+k);
z>>=1;++k;
}
}
else cout<<"-";
cout<<"\n";
}
cout<<"\n";
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: