您的位置:首页 > 其它

hdu2019——数列有序解题报告

2013-02-26 16:19 561 查看
原题:

Problem Description
有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。



Input
输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。



Output
对于每个测试实例,输出插入新的元素后的数列。



Sample Input
3 3
1 2 4
0 0




Sample Output
1 2 3 4




源码:

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
    int n,m;
    int a[101];
    while(scanf("%d%d",&n,&m)&&(n!=0||m!=0))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        a
=m;
        sort(a,a+1+n);
        for(int s=0; s<n; s++)
        {
            printf("%d ",a[s]);
        }
        printf("%d\n",a
);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: