您的位置:首页 > 理论基础 > 计算机网络

poj1273——网络流(sap)

2013-02-26 10:24 295 查看
Drainage Ditches
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 45117Accepted: 16954
Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's
clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection
1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to
Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4

1 2 40

1 4 20

2 4 20

2 3 30

3 4 10

Sample Output

50

Source

USACO 93

解析:

         很裸的一道求最大流的题,这也是本人网络流的入门练习题。。。

        我用的是sap标号法。。。

代码:

#include<cstdio>
#include<iostream>
#define min(a,b) ((a)<(b)?(a):(b))
using namespace std;
const int oo=1000000000,maxn=200+10;

int sum,n,m,g[maxn][maxn],c[maxn][maxn],f[maxn][maxn],sumd[maxn],d[maxn],x,y,z,flow,ans;

void readdata()
{
//    scanf("%d%d",&m,&n);
memset(g,0,sizeof(g));
memset(f,0,sizeof(f));
memset(d,0,sizeof(d));
memset(sumd,0,sizeof(sumd));
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&x,&y,&z);
g[x][y]+=z;
c[x][y]+=z;
//cout<<x<<' '<<y<<' '<<z<<' ';
}
}

int dfs(int u,int flow)
{
int tmp,i,sum;
if(u==n) return(flow);
sum=0;
for(i=1;i<=n;i++)
{
if(g[u][i]>0 && d[u]==d[i]+1)
{
tmp=dfs(i,min(g[u][i],flow-sum));
g[u][i]-=tmp;
g[i][u]+=tmp;
if(c[u][i]>0) f[u][i]+=tmp; else f[i][u]-=tmp;
sum=sum+tmp;
if(sum==flow)return sum;
}
}
if(d[1]>=n) return sum;
sumd[d[u]]--;
if(sumd[d[u]]==0) d[1]=n;
d[u]++;
sumd[d[u]]++;
return sum;
}

void work()
{
ans=0;
sumd[0]=n;
while(d[1]<n)
{
flow=dfs(1,oo);
ans+=flow;
}
printf("%d\n",ans);
}

int main()
{
freopen("ditch.in","r",stdin);
freopen("ditch.out","w",stdout);
while(scanf("%d%d",&m,&n)!=EOF)
{
readdata();
work();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: