您的位置:首页 > 其它

POJ3278--Catch That Cow

2013-02-25 23:30 435 查看
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point
N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point
K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or
X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and
K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#include <string>
using namespace std;
#define maxn 200008 //注意这里开大些。不然2*之后可能越界。。贡献了一次runtime error
int dis[maxn];
int main()
{
int n,k;
while(scanf("%d%d",&n,&k)==2)
{
memset(dis,0x3f,sizeof(dis));
dis
=0;
queue <int> q;
q.push(n);
while(!q.empty())
{
int	p=q.front();
q.pop();
if(p==k) break;
if(p>=1&&dis[p]+1<dis[p-1])
{
q.push(p-1);
dis[p-1]=dis[p]+1;
}
if(p<k&&dis[p]+1<dis[p+1])
{
q.push(p+1);
dis[p+1]=dis[p]+1;
}
if(p<k&&dis[p]+1<dis[2*p])
{
q.push(2*p);
dis[2*p]=dis[p]+1;
}
}
cout<<dis[k]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: