您的位置:首页 > 其它

488 - Triangle Wave

2013-02-20 18:27 253 查看
Triangle Wave
In this problem you are to generate a triangular wave form according to a specified pair of Amplitude and Frequency.

Input and Output

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

Each input set will contain two integers, each on a separate line. The first integer is the Amplitude; the second integer is the Frequency.

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For the output of your program, you will be printing wave forms each separated by a blank line. The total number of wave forms equals the Frequency, and the horizontal ``height'' of each wave equals the Amplitude. The Amplitude will never be greater than nine.

The waveform itself should be filled with integers on each line which indicate the ``height'' of that line.

NOTE: There is a blank line after each separate waveform, excluding the last one.

Sample Input

1

3
2

Sample Output

1
22
333
22
1

1
22
333
22
1


#include"stdio.h"
#include"stdlib.h"
int main()
{ int n,a,b,i,k,j;
scanf("%d ",&n);
while(n--)
{scanf("%d",&a);
scanf("%d",&b);
while(b--)
{ for(i=1;i<=a;i++)//前半段输出;
{for(k=0;k<i;k++)
printf("%d",i);
printf("\n");}
for(i=a-1;i>0;i--)//后半段输出;
{for(k=0;k<i;k++)
printf("%d",i);
printf("\n");}
if(b!=0)//控制最后一组不隔行;
printf("\n");
}
if(n!=0)//控制最后一组不隔行;
printf("\n");
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: