您的位置:首页 > 其它

HDOJ 1019 Least Common Multiple

2013-02-18 20:58 295 查看


Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20538 Accepted Submission(s): 7660



Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers
in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output

105
10296


Source

East Central North America 2003, Practice

Recommend

JGShining

求n个数的最小公倍数,就是先求前两个,用结果和第三个求最小公倍数。。。以此类推

#include <iostream>
using namespace std;
int gcd(int,int);
int main(int argc, char *argv[])
{
int a,n,m; long long s;
cin>>m;
for (int i=1;i<=m;++i){
cin>>n; s=1;
for(int j=1;j<=n;++j){
cin>>a;
s=s*a/gcd(s,a);
}
cout<<s<<endl;
}
return 0;
}

int gcd(int a,int b){
return b?gcd(b,a%b):a;
}


kdwycz的网站: http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: