您的位置:首页 > 其它

HDOJ 1013 Digital Roots

2013-02-16 21:48 435 查看
Digital Roots


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34630 Accepted Submission(s): 10580



Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0


Sample Output

6
3


Source

Greater New York 2000

第一次写的TLE代码

#include <iostream>
using namespace std;
int main(int argc, char *argv[])
{
int a,i;
cin>>a;
while (a!=0){
while (a>9){
i=0;
while (a){
i+=(a%10);
a/=10;
}
a=i;
}
cout<<a<<endl;
cin>>a;
}
return 0;
}


一开始是想用字符串的,TLE后用字符串读入,因为copy了之前的代码,导致思路混乱WA了N次。。。。我想拍死自己啊

混乱的修改N遍的代码。。。。

#include <iostream>
#include <string>
using namespace std;
int main(int argc, char *argv[])
{
string a; int b,i,j;
cin>>a;
while (a!="0"){
b=0;
for(i=0;i<a.length();++i) b+=a[i]-'0';
j=b;
while (b>9){
j=0;
while (b){
j+=(b%10);
b/=10;
}
b=j;
}
cout<<j<<endl;
cin>>a;
}
return 0;
}


去看了别人的程序。。。根本不需要用循环算、、、mod9的原理我不太清楚,要好好学数学啊

#include<stdio.h>
int main()
{
int i,m;
char s[1000];
while(scanf("%s",s)==1&&s[0]!='0'){
for(m=i=0;s[i];i++)
m+=s[i]-'0';
printf("%d\n",m%9==0?9:m%9);    //很靓啊哈~
}
return 0;
}


kdwycz的网站: http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: