您的位置:首页 > 其它

POJ2387--Til the Cows Come Home--Dijkstra算法裸题

2013-02-08 01:10 351 查看
Description
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output
90

Hint
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.
不说了,裸的Dijkstra算法套路,看不懂的可以看下我的Dij
#include <iostream>
#include <cstdio>
using namespace std;
#define maxn 1006
#define inf 0x7fffffff
int w[maxn][maxn];
int d[maxn];
bool vis[maxn];
inline int min(int a,int b)
{
return a>b?b:a;
}
int main()
{
int t,n;//t是边,n是多少个地标
//从N到1
while(scanf("%d%d",&t,&n)==2)
{
memset(w,0x3f,sizeof(w));
int u,v,len;
for(int i=1;i<=t;i++)
{
scanf("%d%d%d",&u,&v,&len);
w[u][v]=w[v][u]=min(w[u][v],len);
}
d
=0;
for(int i=1;i<n;i++)
{
d[i]=inf;
}
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++)
{
int m=inf,x;
for(int j=1;j<=n;j++)
{
if(!vis[j]&&d[j]<=m)
{
m=d[x=j];
}
}
vis[x]=1;
for(int j=1;j<=n;j++)
{
d[j]=min(d[j],d[x]+w[x][j]);
}
}
printf("%d\n",d[1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息