您的位置:首页 > 其它

HDU2602--Bone Collector--动态规划

2013-02-04 14:32 148 查看
 

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

#include <iostream>
#include <cstdio>
using namespace std;
int dp[1008][1008];
int value[1008];
int vol[1008];
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,v;
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&v);
for(int i=1;i<=n;i++)
{
scanf("%d",&value[i]);
}
for(int i=1;i<=n;i++)
{
scanf("%d",&vol[i]);
}
for(int i=1;i<=n;i++)//石头个数
{
for(int j=0;j<=v;j++)//背包体积不断变大
{
dp[i][j]=dp[i-1][j];
if(j>=vol[i])
{
dp[i][j]=max(dp[i][j],dp[i-1][j-vol[i]]+value[i]);
}
}
}
cout<<dp
[v]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Bone Collector HDU2602