您的位置:首页 > 其它

HDU1003--Max Sum--最大连续和

2013-02-04 14:28 465 查看
Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

#include <iostream>
#include <cstdio>
using namespace std;
int A[100008];
#define INF 0x3f
int maxmax(int a,int b)
{
return a>b?a:b;
}
int main()
{
int t;
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
int n;
scanf("%d",&n);
for(int j=1;j<=n;j++)
{
scanf("%d",&A[j]);
}
int sum=0,max=-INF;
int head=1,tail=1;
for(int j=1;j<=n;j++)
{
sum+=A[j];
if(max<sum)
{
tail=j;
max=sum;
}
sum=sum<0?0:sum;
}
int sum1=0;
for(int j=1;j<=n;j++)
{
sum1+=A[j];
if(sum1==max)
{
break;
}
if(sum1<0)
{
sum1=0;
head=j+1;
}
}
if(i!=t)
cout<<"Case "<<i<<":"<<endl<<max<<" "<<head<<" "<<tail<<endl<<endl;
else cout<<"Case "<<i<<":"<<endl<<max<<" "<<head<<" "<<tail<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU1003 最大连续和