您的位置:首页 > 其它

周赛

2013-01-31 19:02 141 查看


题目描述

Babs sells boxes and lots of them. All her boxes are rectangular but come in many different sizes. Babs wants to create a really eye-catching display by stacking, one on top of another, as many boxes as she can outside her store. To maintain neatness and stability,
she will always have the sides of the boxes parallel but will never put a box on top of another if the top box sticks out over the bottom one. For example, a box with base 5-by-10 can not be placed on a box with base 12-by-4.

Of course the boxes have three dimensions and Babs can orient the boxes anyway she wishes. Thus a

5-by-10-by-12 box may be stacked so the base is 5-by-10, 5-by-12, or 10-by-12.

For example, if Babs currently has 4 boxes of dimensions 2-2-9, 6-5-5, 1-4-9, and 3-1-1, she could stack up to 3 boxes but not all four. (For example, the third box, the first box, then the last box, appropriately oriented. Alternatively, the second box could
replace the third (bottom) box.)

Babs’ stock rotates, so the boxes she stacks outside change frequently. It’s just too much for Babs to figure out and so she has come to you for help. Your job is to find the most boxes Babs can stack up

given her current inventory. Babs will have no more than 10 different sized boxes and will use at most one box of any size in her display.


输入

A positive integer n (n ≤ 10) will be on the first input line for each test case. Each of the next n lines will contain three positive integers giving the dimensions of a box. No two boxes will have identical dimensions. None of the dimensions will exceed 20.
A line with 0 will follow the last test case.


输出

For each test case, output the maximum number of boxes Babs can stack using the format given below.


示例输入

4
2 2 9
6 5 5
1 4 9
3 1 1
3
2 4 2
1 5 2
3 4 1
0



示例输出

Case 1: 3
Case 2: 3



提示

题意:给你n个长方体,给出你长,宽,高的值,让你把它们堆在一起,要求,底下的长和宽一定大于上面的长和宽,求最多能放多少个长方体。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
int a;
int b;
int c;
} Node[1001];
int n;
int Max;
int visit[1001];
void DFS(int ax,int ay,int ah,int t)
{
if(Max<t)
{
Max=t;
}
for(int i=0; i<n; i++)
{
if(visit[i]==0)
{
if(Node[i].a<=ax&&Node[i].b<=ay)
{
visit[i]=1;
DFS(Node[i].a,Node[i].b,Node[i].c,t+1);
visit[i]=0;
}
if(Node[i].a<=ax&&Node[i].c<=ay)
{
visit[i]=1;
DFS(Node[i].a,Node[i].c,Node[i].b,t+1);
visit[i]=0;
}
if(Node[i].b<=ax&&Node[i].c<=ay)
{
visit[i]=1;
DFS(Node[i].b,Node[i].c,Node[i].a,t+1);
visit[i]=0;
}
}
}
}
int main()
{
int step=1;
int t[4];
while(scanf("%d",&n)!=EOF)
{
if(n==0)  break;
memset(visit,0,sizeof(visit));
for(int i=0; i<n; i++)
{
scanf("%d%d%d",&t[0],&t[1],&t[2]);
sort(t,t+3);
Node[i].a=t[2];
Node[i].b=t[1];
Node[i].c=t[0];
}
Max=0;
DFS(1001,1001,1001,0);
printf("Case %d: %d\n",step,Max);
step++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: