您的位置:首页 > 其它

hdu 3449 Consumer 依赖背包

2013-01-24 21:03 363 查看
依赖背包 事实上,这是一种树形DP,其特点是每个父节点都需要对它的各个儿子的属性进行一次DP以求得自己的相关属性。

fj打算去买一些东西,在那之前,他需要一些盒子去装他打算要买的不同的物品。每一个盒子有特定要装的东西(就是说如果他要买这些东西里的一个,他不得不先买一个盒子)。每一种物品都有自己的价值,现在FJ只有W元去购物,他打算用这些钱买价值最高的东西。


Consumer


Time Limit : 4000/2000ms (Java/Other) Memory Limit : 32768/65536K (Java/Other)


Total Submission(s) : 1 Accepted Submission(s) : 0


Problem Description

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy
the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.

Input

The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number
goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)

Output

For each test case, output the maximum value FJ can get

Sample Input

3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60


Sample Output

210


#include<stdio.h>
#include<string.h>
#define wsize 100010
#define nsize 65
#define msize 11
int dp[nsize][wsize];
int n,t,box,num;
int max(int a,int b)
{
return a>b?a:b;
}
int main ()
{
int i,j,k;
while(scanf("%d %d",&n,&t)!=EOF)
{
memset(dp,-1,sizeof(dp));   //有依赖关系,要赋初值-1
memset(dp[0],0,sizeof(dp[0]));
for(i=1;i<=n;i++)
{
scanf("%d %d",&box,&num);
for(k=box;k<=t;k++)
dp[i][k]=dp[i-1][k-box];  //先让i层买盒子,因为盒子没有价值,所以直接等于上一层的花费+盒子钱
for(j=0;j<num;j++)             //在已花费盒子钱的基础上,此时再对dp[i]层做01背包,即i层一个盒子多种物品的最大价值
{
int c,w;
scanf("%d %d",&c,&w);
for(k=t;k>=c;k--)
{
if(dp[i][k-c]!=-1)  //注意依赖背包有不可能的情况,这里即k买不到盒子和这个物品,不能装物品
dp[i][k]=max(dp[i][k],dp[i][k-c]+w);  // 这里不能dp[i][k]=max(dp[i][j],dp[i][k-box-c]+w) 因为已经										买过盒子了,这个表达式代表一个盒子基础上一个物品带一个盒子
}
}
for(j=0;j<=t;j++)
{               // 不买这组    买这组
dp[i][j]=max(dp[i-1][j],dp[i][j]);  //不要忘了考虑不选当前组的情况(不是必选)
}
}
printf("%d\n",dp
[t]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: