您的位置:首页 > 运维架构

hdu 1011 Starship Troopers 简单树形DP

2013-01-22 21:05 447 查看



就是一个普通的依赖背包,一个房间是一个物品,房间中所有bugs是花费,brains是重量,没有留人收集brains一说
要注意背包的概念和树形背包是无向边的情况,无相加两条边对结果没有影响


Starship Troopers


Time Limit : 10000/5000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 1 Accepted Submission(s) : 1


Problem Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some
of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is
one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight
all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the
problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines
give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers,
which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1


Sample Output

50
7


#include<stdio.h>
#include<string.h>
#define size 120
#define INF 1<<30
struct node{
int from;
int to;
int next;
}edge[size*2];
int c[size],w[size],n,m,tot,vis[size];
int dp[size][size],f[size][size];
int head[size];
void add(int a,int b)
{
edge[tot].from=a;
edge[tot].to=b;
edge[tot].next=head[a];
head[a]=tot++;
}
int max(int a,int b)
{
return a>b?a:b;
}
void dfs(int u)
{
int p=(c[u]+19)/20;
int i,j,k,r;
vis[u]=1;

for(i=head[u];i!=-1;i=edge[i].next)
{
r=edge[i].to;
if(!vis[r])
dfs(r);
for(j=m;j>=1;j--)
{
for(k=1;k<=j;k++)
{
f[u][j]=max(f[u][j],f[u][j-k]+dp[r][k]);
}
}
}
for(i=p;i<=m;i++)
{
dp[u][i]=f[u][i-p]+w[u];
}
}

int main()
{
int i,j,k,l;
while(scanf("%d %d",&n,&m)!=EOF)
{
if(n==-1&&m==-1)
break;
tot=0;
memset(vis,0,sizeof(vis));
memset(dp,0,sizeof(dp));
memset(f,0,sizeof(f));
memset(head,-1,sizeof(head));
for(i=1;i<=n;i++)
scanf("%d %d",&c[i],&w[i]);
for(i=0;i<n-1;i++)
{
int a,b;
scanf("%d %d",&a,&b);
add(a,b);
add(b,a);
}
if(m==0)
{
printf("0\n");
continue;
}
if(n>1)
{
dfs(1);
printf("%d\n",dp[1][m]);

}
else if(n==1)
{

printf("%d\n",c[1]>m*20?0:w[1]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: