您的位置:首页 > 其它

Bone Collector (简单的0-1背包问题) HDU

2013-01-20 14:19 405 查看

Bone Collector

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 7 Accepted Submission(s) : 3
[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1


[align=left]Sample Output[/align]

14


问题 描述: 给出样品的个数 和背包的大小

给出每个样品的大小和价值 求 背包最大的价值

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int dp[1001];
int main()
{
int test;
while(scanf("%d",&test)!=EOF)
{
while(test--)
{
int v[1001];
int w[1001];
memset(dp,0,sizeof(dp));
int n,weight;
scanf("%d%d",&n,&weight);
for(int i=1; i<=n; i++)
scanf("%d",&v[i]);
for(int i=1; i<=n; i++)
scanf("%d",&w[i]);
dp[0]=1;
for(int i=1; i<=n; i++)
{
for(int j=weight; j>=w[i]; j--)
{
if(dp[j]<dp[j-w[i]]+v[i])
dp[j]=dp[j-w[i]]+v[i];
}
}
int max=0;
for(int i=0; i<=weight; i++)
if(dp[i]>max) max=dp[i];
printf("%d\n",max-1);
}
}
return 0;
}
/*
1 5 10 1 2 3 4 5 5 4 3 2 1
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: