您的位置:首页 > 其它

HDU2054:A == B ?

2013-01-14 17:27 169 查看
Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".


Input
each test case contains two numbers A and B.



Output
for each case, if A is equal to B, you should print "YES", or print "NO".


Sample Input
1 2
2 2
3 3
4 3




Sample Output
NO
YES
YES
NO




//水题,关键在小数点



#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
    char a[100000],b[100000];
void change(char s[])
{
    int i,len;
    len  = strlen(s);
    if(strstr(s,"."))
    {
        for(i = len-1; s[i] == '0'; i--)
        {
            s[i] = '\0';
            len--;
        }
    }
    if(s[len-1] == '.')
        s[len-1] = '\0';
}

int main()
{

    while(scanf("%s%s",a,b)!=EOF)
    {
        change(a);
        change(b);
        if(strcmp(a,b))
        printf("NO\n");
        else
        printf("YES\n");
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: