您的位置:首页 > 其它

HDU 1009 FatMouse' Trade

2012-12-29 10:16 309 查看

FatMouse' Trade

http://acm.hdu.edu.cn/showproblem.php?pid=1009

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 28122 Accepted Submission(s): 9028

[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

[align=left]Sample Input[/align]
[align=left] [/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

[align=left]Sample Output[/align]
[align=left] [/align]

13.333
31.500

[align=left]Author[/align]
CHEN, Yue

[align=left]Source[/align]
ZJCPC2004

[align=left]Recommend[/align]
JGShining

sort版本

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>

using namespace std;

struct node{
int j,f;
double r;
}food[1005];

int cmp(node a,node b){
return a.r>b.r;
}

int main(){
int m,n;
while(scanf("%d%d",&m,&n)){
if(m==-1 && n==-1)
break;
int i;
for(i=0;i<n;i++){
scanf("%d%d",&food[i].j,&food[i].f);
food[i].r=(double)food[i].j/food[i].f;
}
//qsort(food,n,sizeof(node),cmp);
sort(food,food+n,cmp);
double ans=0;
for(i=0;i<n;i++)
if(m>=food[i].f){
m-=food[i].f;
ans+=food[i].j;
}else{
ans+=(food[i].j*1.0/food[i].f)*m;
break;
}
printf("%.3lf\n",ans);
}
return 0;
}


qsort版本

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>

using namespace std;

struct node{
int j,f;
double r;
}food[1005];

int cmp(const void *a,const void *b){
node c=*(node *)a;
node d=*(node *)b;
if(c.r>d.r)
return -1;
else
return 1;
}

int main(){
int m,n;
while(scanf("%d%d",&m,&n)){
if(m==-1 && n==-1)
break;
int i;
for(i=0;i<n;i++){
scanf("%d%d",&food[i].j,&food[i].f);
food[i].r=(double)food[i].j/food[i].f;
}
qsort(food,n,sizeof(food[0]),cmp);
//sort(food,food+n,cmp);
double ans=0;
for(i=0;i<n;i++)
if(m>=food[i].f){
m-=food[i].f;
ans+=food[i].j;
}else{
ans+=(food[i].j*1.0/food[i].f)*m;
break;
}
printf("%.3lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: