您的位置:首页 > 其它

hdu 4336 Card Collector

2012-12-15 07:28 260 查看

Card Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1470 Accepted Submission(s): 655

Special Judge

Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.


Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating
the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.


Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.


Sample Input
1
0.1
2
0.1 0.4




Sample Output
10.000
10.500




Source
2012 Multi-University
Training Contest 4


Recommend
zhoujiaqi2010


概率题,容斥原理,枚举所有的期望值,再减去重的部分,也可以用概率dp做貌似。。。
貌似说是样例有问题。。。听说是special judge这种题会有多种结果,所以我觉得最后是输出小数点后三位还是小数点后六位什么的,也许并不重要了。

// 容斥原理
// 这个题的期望就是1/p[i]
// Ans=sigma(1/p[i])-sigma(1/(p[i]+p[j]))+...
//        1<=i<=n         1<=i,j<=n
//奇数项和时为加,偶数项和时为减
#include <cstdio>
#include <cstring>
using namespace std;
double p[20];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%lf",&p[i]);
        double ans=0;
        for(int i=1;i<(1<<n);i++)
        {
            int cnt=0;
            double sum=0;
            for(int j=0;j<n;j++)
            {
                if(i&(1<<j))
                {
                    sum+=p[j];
                    cnt++;
                }
            }
            if(cnt&1)
                ans+=1/sum;
            else
                ans-=1/sum;
        }
        printf("%lf\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: