您的位置:首页 > 其它

hdu 1342 Lotto

2012-12-13 10:28 351 查看
题目地址地址:http://acm.hdu.edu.cn/showproblem.php?pid=1342

题目:


Lotto


Problem Description

In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S. 

Input

The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.

Output

For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.

Sample Input


7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0


Sample Output


1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34


Source

University of Ulm Local Contest 1996

结题报告:主要联系深搜,其实每个算法都是一种思想,只要理解了,代码可以千差万别,而且书写方式也可以相差很大,用到的小技巧上也会有很大的区别。

代码一:

#include<stdio.h>
#include<string.h>
#define maxn 80
int a[maxn];
int vis[maxn];
int n,count;
void dfs(int x)
{
int i,j;
if(count==6)
{
for(i=1,j=1;i<=n,j<6;i++)
if(vis[i]==1)
{
printf("%d ",a[i]);
j++;
}
for(;i<=n;i++)
{
if(vis[i]==1)
printf("%d",a[i]);
}
puts("");
return ;
}
for(i=x;i<=n;i++)
{
if(vis[i]==0)
{
vis[i]=1;
count++;
dfs(i+1);
vis[i]=0;
count--;
}
}
}
int main()
{
int i,j,k;
int digit=0;
while(scanf("%d",&n)!=EOF && (n!=0))
{
for(i=1;i<=n;i++)scanf("%d",&a[i]);
if(digit!=0) puts("");
digit=1;
memset(vis,0,sizeof(vis));
count=0;
dfs(1);

}
return 0;
}

代码二:

#include<cstdio>
#include<cstring>
int rec[20],num[20],n,x;
void dfs(int dep,int cur)
{
if(dep==6)
{
for(int i=0;i<5;i++) printf("%d ",rec[i]);

printf("%d",rec[5]);
puts("");
return ;
}
for(int j=cur;j<n;j++)
{
rec[dep]=num[j];
dfs(dep+1,j+1);
}
}
int main()
{
int i,j;
int flag=0;
while(scanf("%d",&n),n)
{
if(flag) puts("");
for(i=0;i<n;i++) scanf("%d",&num[i]);
dfs(0,0);
flag=1;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: